Author Topic: Laptop likes to lock up.  (Read 3610 times)

Bobbias

  • #1 Poster
  • Hero Member
  • *****
  • Posts: 7189
  • 404 Avatar not found.
    • View Profile
    • Magnetic Architect
Laptop likes to lock up.
« on: December 22, 2011, 08:02:18 PM »
So, my laptop has a tendency to freeze up for a while after leaving it for a little while (20 or 30 minutes, sometimes less). It doesn't always do it, but every once in a while it locks up pretty hard, and takes forever to start responding.

The screen will turn back on, but the mouse will be frozen (most of the time), or sometimes move around really jumpy before finally freezing in place somewhere.

I've noticed that the network activity light seems to be locked in the on state or sometimes flashes really slowly (compared to the quicker flashing it does when the computer is running normally).

Is there any way to track what exactly is happening when it locks up like that?

EDIT:
I've got a ton of error messages in the Event Viewer from ACEEventLog that seem to coincide with the time the computer locked up:
Code: [Select]
Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:56:31 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000024: 2011-12-22 19:56:31:407    Could not find Type [ATI.ACE.CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard.DB_TutorialInfoCentre] from [CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard] in assembly [CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard]
 Error      Called by: ATI.ACE.LOG.Foundation.Services::LoadAssembly                                                    processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation, Version=3.5.4268.23099, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:56:31.000000000Z" />
    <EventRecordID>49568</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000024: 2011-12-22 19:56:31:407    Could not find Type [ATI.ACE.CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard.DB_TutorialInfoCentre] from [CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard] in assembly [CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard]
 Error      Called by: ATI.ACE.LOG.Foundation.Services::LoadAssembly                                                    processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation, Version=3.5.4268.23099, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:56:31 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000023: 2011-12-22 19:56:31:406    Exception <Load>: Could not load file or assembly 'CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard' or one of its dependencies. The system cannot find the file specified.
 Exception  Called by: ATI.ACE.LOG.Foundation.Services::LoadAssembly                                                    processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation, Version=3.5.4268.23099, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
************************************************************************************************************************

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:56:31.000000000Z" />
    <EventRecordID>49567</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000023: 2011-12-22 19:56:31:406    Exception &lt;Load&gt;: Could not load file or assembly 'CLI.AIB.TutorialInfoCentre.Tutorial.Dashboard' or one of its dependencies. The system cannot find the file specified.
 Exception  Called by: ATI.ACE.LOG.Foundation.Services::LoadAssembly                                                    processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation, Version=3.5.4268.23099, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
************************************************************************************************************************
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:56:02 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000022: 2011-12-22 19:56:02:295    Could not load file or assembly 'file:///C:\Program Files (x86)\ATI Technologies\ATI.ACE\Branding\BrandingResources.dll' or one of its dependencies. The system cannot find the file specified.
 Error      Called by: ATI.ACE.LOG.Foundation.Implementation.Branding::.ctor                                            processID:01544 threadID:(CCCThreadNew:Systemtray) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation.Implementation, Version=3.5.4268.23144, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:56:02.000000000Z" />
    <EventRecordID>49566</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000022: 2011-12-22 19:56:02:295    Could not load file or assembly 'file:///C:\Program Files (x86)\ATI Technologies\ATI.ACE\Branding\BrandingResources.dll' or one of its dependencies. The system cannot find the file specified.
 Error      Called by: ATI.ACE.LOG.Foundation.Implementation.Branding::.ctor                                            processID:01544 threadID:(CCCThreadNew:Systemtray) domainName:(CCC.exe                    ) assemblyName:(LOG.Foundation.Implementation, Version=3.5.4268.23144, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:51 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000021: 2011-12-22 19:55:51:683    Failed to get services interface
 Error      Called by: ATI.ACE.CLI.Caste.Fuel.Runtime.RT_FuelAdapter::InternalApply                                     processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Fuel.Runtime, Version=3.5.4268.23166, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:51.000000000Z" />
    <EventRecordID>49565</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000021: 2011-12-22 19:55:51:683    Failed to get services interface
 Error      Called by: ATI.ACE.CLI.Caste.Fuel.Runtime.RT_FuelAdapter::InternalApply                                     processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Fuel.Runtime, Version=3.5.4268.23166, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:51 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000020: 2011-12-22 19:55:51:673    Failed to get services interface
 Error      Called by: ATI.ACE.CLI.Caste.Fuel.Runtime.RT_FuelAdapter::InternalApply                                     processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Fuel.Runtime, Version=3.5.4268.23166, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:51.000000000Z" />
    <EventRecordID>49564</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000020: 2011-12-22 19:55:51:673    Failed to get services interface
 Error      Called by: ATI.ACE.CLI.Caste.Fuel.Runtime.RT_FuelAdapter::InternalApply                                     processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Fuel.Runtime, Version=3.5.4268.23166, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:49 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000019: 2011-12-22 19:55:49:812    FAILED:ADL_Display_SLSGrid_Caps and return value is: -1
 Error      Called by: ATI.ACE.CLI.Caste.Graphics.Runtime.RT_GraphicsAdapter_N::CheckSLSSupported                       processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Graphics.Runtime, Version=3.5.4268.23118, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:49.000000000Z" />
    <EventRecordID>49563</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000019: 2011-12-22 19:55:49:812    FAILED:ADL_Display_SLSGrid_Caps and return value is: -1
 Error      Called by: ATI.ACE.CLI.Caste.Graphics.Runtime.RT_GraphicsAdapter_N::CheckSLSSupported                       processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(CLI.Caste.Graphics.Runtime, Version=3.5.4268.23118, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:49 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000018: 2011-12-22 19:55:49:714    DPPE - Executing ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:49.000000000Z" />
    <EventRecordID>49562</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000018: 2011-12-22 19:55:49:714    DPPE - Executing ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:49 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000017: 2011-12-22 19:55:49:626    CPUP - Executing ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:49.000000000Z" />
    <EventRecordID>49561</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000017: 2011-12-22 19:55:49:626    CPUP - Executing ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:49 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000016: 2011-12-22 19:55:49:601    DPPE - In ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="ACEEventLogSource" />
    <EventID Qualifiers="0">0</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2011-12-23T00:55:49.000000000Z" />
    <EventRecordID>49560</EventRecordID>
    <Channel>ACEEventLog</Channel>
    <Computer>Bobbias-PC</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0000000016: 2011-12-22 19:55:49:601    DPPE - In ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
</Data>
  </EventData>
</Event>

Log Name:      ACEEventLog
Source:        ACEEventLogSource
Date:          12/22/2011 7:55:49 PM
Event ID:      0
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      Bobbias-PC
Description:
0000000015: 2011-12-22 19:55:49:592    CPUP - In ActivePowerSchemeChangedEventHandler
 Error      Called by: ATI.ACE.NEWAEM.Foundation.RemoteActionAdapter::InvokeAction                                      processID:01544 threadID:(                ) domainName:(CCC.exe                    ) assemblyName:(NEWAEM.Foundation, Version=3.5.4268.23109, Culture=neutral, PublicKeyToken=90ba9c70f846762e)
------------------------------------------------------------------------------------------------------------------------
(That's only a partial log)
Installing newest drivers right now.

Hmm, still happening. Anyone know where I can send this shit to AMD and bitch them out for their drivers not working right? (And not just be a useless forum...)
« Last Edit: December 23, 2011, 06:23:30 PM by Bobbias »
This is going in my sig. :)


BANNED FOR BAD PUNS X_x

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5432
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Laptop likes to lock up.
« Reply #1 on: January 14, 2012, 04:14:10 AM »
Uh, if that much of the Catalyst Control Center broke I think the problem is far beyond what AMD is responsible for. If you read the messages it's having a hard time loading just about every single component of it. It almost looks like something that would happen after a botch System Restore.

Completely uninstall the drivers before installing the new ones and see if that fixes it, or at least reduces the number of error messages.

What make/model is the laptop?
¯\_(ツ)_/¯

Bobbias

  • #1 Poster
  • Hero Member
  • *****
  • Posts: 7189
  • 404 Avatar not found.
    • View Profile
    • Magnetic Architect
Re: Laptop likes to lock up.
« Reply #2 on: January 15, 2012, 09:06:54 AM »
I've fully uninstalled, and then reinstalled the drivers. Still happening. Happening a bit less often, but still happening.

It's an Acer Aspire 5542-G. I've never used system restore (I try to avoid if because it can fuck stuff like this up pretty hard).
This is going in my sig. :)


BANNED FOR BAD PUNS X_x

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5432
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Laptop likes to lock up.
« Reply #3 on: January 15, 2012, 01:52:57 PM »
How about downgrading to a previous driver version?  I've had good luck with 11.8 for a while (I'm a slacker when it comes to upgrading my video card drivers).
¯\_(ツ)_/¯

Bobbias

  • #1 Poster
  • Hero Member
  • *****
  • Posts: 7189
  • 404 Avatar not found.
    • View Profile
    • Magnetic Architect
Re: Laptop likes to lock up.
« Reply #4 on: January 15, 2012, 05:31:22 PM »
I think 11.8 is what I was originally running. I could be wrong.

I mean, this isn't a HUGE deal, because I can just force a hard reboot, and start the computer again. But it's an inconvenience, and I really have to wonder what on earth is causing this.

I supposed I could remove everything and only install the driver itself, but I prefer having the CCC in case I want to be able to get some control over things.
This is going in my sig. :)


BANNED FOR BAD PUNS X_x

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5432
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Laptop likes to lock up.
« Reply #5 on: January 15, 2012, 11:36:35 PM »
The main thing that I'd worry about, especially in the case of hard lockups, is hardware failure.  I haven't heard of any ATI chips committing seppuku (like numerous generations of NVIDIA laptop chips -- including one that I happen to own...which no longer works, by the way -- do), but I do know of several laptop models, particularly HPs, that will kill themselves for the same reason that older Xbox 360s do.

You might as well keep CCC in there, as that's not the problem here.  Something just happened to nuke your install of CCC.  It could have happened during one of the hard locks, even.  CCC does talk to the driver, but it should never cause crashes unless you're doing some heavy overclocking.
¯\_(ツ)_/¯