Author Topic: Planned Outage - Saturday, March 5, 2016 at 7PM EST  (Read 2973 times)

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5366
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Planned Outage - Saturday, March 5, 2016 at 7PM EST
« on: March 05, 2016, 04:00:06 AM »
I'm finally going to convert freyr.spectere.net (that's this server!) to a new distro later. I doubt it'll impact anyone.

This has been a long time coming, and considering how bloody slow this tiny-ass site is for no apparent reason (not to mention the fact that Arch is so fucking busted right now that I can't even do security updates!) I think it's a good time to get this taken care of.

After this experience, I think it's safe to say that this server is the last Arch install I'll willingly use. Good god, what a fucking nightmare.
¯\_(ツ)_/¯

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5366
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Planned Outage - Saturday, March 5, 2016 at 7PM EST
« Reply #1 on: March 06, 2016, 12:10:22 AM »
And we're mostly back! Some services still need to be configured (i.e. all subdomains are still down), but things seem to be running along pretty nicely.

And I have to say, after how badly the site was performing before, this feels like a breath of fresh air. Things feel fast again!
¯\_(ツ)_/¯

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5366
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Planned Outage - Saturday, March 5, 2016 at 7PM EST
« Reply #2 on: March 06, 2016, 01:12:41 AM »
files.spectere.net and Alice's domain are both back. I think we're golden!

Just as an FYI, I made the jump from Apache+mod_php to nginx+php_fpm so some things may be broken/different (most notably, friendly URLs no longer work because .htaccess is no longer a thing). Please let me know if you find anything that doesn't work. Thanks! <3
¯\_(ツ)_/¯

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5366
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Planned Outage - Saturday, March 5, 2016 at 7PM EST
« Reply #3 on: March 11, 2016, 05:25:10 PM »
So I forgot to switch the forum out of maintenance mode. Normally SMF has a big alert on the front page if the forum is in maintenance mode (since admins can still log in and post normally), but apparently it decided not to display it.

Yeah...sorry 'bout that! :s
¯\_(ツ)_/¯

Bobbias

  • #1 Poster
  • Hero Member
  • *****
  • Posts: 7162
  • 404 Avatar not found.
    • View Profile
    • Magnetic Architect
Re: Planned Outage - Saturday, March 5, 2016 at 7PM EST
« Reply #4 on: March 12, 2016, 10:42:49 PM »
I was seeing a maintenance mode thing for the past few days. Was wondering what was going on.
This is going in my sig. :)


BANNED FOR BAD PUNS X_x

Spectere

  • \m/ (-_-) \m/
  • Administrator
  • Hero Member
  • *****
  • Posts: 5366
  • printf("%s\n", "Hi!");
    • View Profile
    • spectere.net
Re: Planned Outage - Saturday, March 5, 2016 at 7PM EST
« Reply #5 on: March 14, 2016, 01:47:42 AM »
Yep. After thinking about it, I think that SMF hides the administrative alert in the user header. You know, the one that you can collapse.

Suffice it to say, I have it collapsed because it's a waste of space.

Who in the world thought that putting it there was a good idea? I have no idea. I would have put a big, bright box on top that said "THE FORUM IS IN MAINTENANCE MODE, DIPSHIT," but that's just me.

But oh well. At least everything loads a lot faster!

Edit: Also, if you do run into any site issues in the future, feel free to badger me on Twitter: @Spectere or via e-mail (spectere at gmail).
« Last Edit: March 14, 2016, 01:49:18 AM by Spectere »
¯\_(ツ)_/¯